مشکل سازگاری importها در پایتون

August 2020

در این ویدیو با دو تکنیکی که در گذشته برای سازگار کردن نسخه‌های مختلف پایتون استفاده میشد آشنا میشوید. در سال 2008 برای اینکه ایرادات پایتون برطرف شود و این زبان برای آینده مناسب باشد، توسعه دهندگان پایتون تصمیم گرفتند که نسخه 3 را توسعه دهند. اما از آنجایی که بسیاری از برنامه‌ها با پایتون نسخه 2 نوشته شده بودند بازنویسی سریع این کدها با نسخه جدید پایتون غیرممکن بود. به همین خاطر توسعه دهندگان پایتون تا سال 2020 دو نسخه از پایتون را به صورت همزمان توسعه میدادند تا برنامه‌نویسان فرصت مهاجرت از پایتون 2 به 3 را داشته باشند.

ارسال نظر

اگر قراره سوالی بپرسید که داخلش کد هست، بهتره از کدتون عکس بگیرید و به ایمیلی که پایین نوشتم بفرستید